XComponent and Combobox without drop down triangle

It took me the better part of a day to fix the following error:

When I added any one of the XComponents provided by Antivia and I previewed my dashboard, the combo boxes were not rendered proberly anymore. The drill down arrow disappeared. Functional the combos still worked.

As another developer had no problems (thus with same settings and patches), I thought it must be one of those bugs which mess up your whole dashboard. So I started to create from scratch the whole dashboard again. And indeed all worked as it should …. untill I added my connections. Suddenly the error was back. Removing the connections and the bug was fixed. So it definetely had to do with connections.

After some trial and error I figured out it had to do with the “enable load cursor” selection. When enabled the bug appears, disable the option and the dahboard works fine.

So instead of building from scratch I could have fixed it by simply removing that option ;-)

Recent Related Posts
Femke Kooij is a dashboard and report designer, developer and educator specializing in SAP | BusinessObjects Dashboards (better known as Xcelsius) and Crystal Reports. She has also a lot of experience with other SAP | BusinessObjects toolings like, Web Intelligence (WebI), Information Design Tool (Universe Designer), BusinessObjects Data Services (BODS) and the overall server platform BusinessObjects Enterprise (Launchpad, CMC). She spends a lot of her time thinking about and sharing her knowledge of Xcelsius to others through her own blog. Lately she is exploring other visualization tools like Qlikview and Tableau. On the later she is also posting some experiences. Currently she is in the employment of Cognizant Technology Solutions. Her blog only contains her personal views, thoughts and opinions. It is not endorsed by Cognizant Technology Solutions nor does it constitute any official communication of Cognizant Technology Solutions.

This entry was posted in Components, Xcelsius and tagged , , , , . Bookmark the permalink.

3 Comments to XComponent and Combobox without drop down triangle

  1. Do you by any chance know where i should go i have some specific questions concerning the combo boxes?

    Hope to hear from you.

    Kind regards,

    Alex

  2. good i appreciate you for sharing this.

  3. pramod says:

    well i always had some issue with load cursor .. i dont check the box .. i figured out the same the combo boxes were flat and square and after unchecking , i got it restored .